Công ty TNHH Công Nghệ Trần Nguyễn
WordPress 5.8.1 chính thức phát hành

WordPress 5.8.1 chính thức phát hành

27/09/2021

Bản phát hành mới nhất này có 60 bản sửa lỗi tính năng và 3 bản sửa lỗi bảo mật. VìWordPress 5.8.1là bản cập nhật bảo mật, chính vì vậy bạn nên cập nhật trang web của mình ngay lập tức! Tất cả các phiên bản kể từ WordPress 5.4 cũng đã được cập nhật.

wordpres 5.8.1wordpres 5.8.1

WordPress 5.8.1là một bản cập nhật bảo mật và bảo trì chu kỳ ngắn. Bản phát hành chính tiếp theo sẽ là phiên bản 5.9.

Bạn có thể tải xuống WordPress 5.8.1 bằng cách tải xuống từWordPress.orghoặc truy cập Trang tổng quan của bạn → Cập nhật và nhấp vào Cập nhật ngay.

Cập nhật bảo mật

3 vấn đề bảo mật ảnh hưởng đến các phiên bản WordPress từ 5.4 đến 5.8. Nếu bạn chưa cập nhật lên WordPress 5.8.1, tất cả các phiên bản WordPress kể từ 5.4 cũng đã được cập nhật để khắc phục các sự cố bảo mật sau:

  • Lỗ hổng tiếp xúc dữ liệu trong API REST
  • Lỗ hổng Cross-Site Scripting (XSS) trong trình chỉnh sửa khối Gutenberg
  • Nhiều lỗ hổng bảo mật từ mức độ nghiêm trọng đến mức độ nghiêm trọng cao trong Thư viện JavaScript Lodash

Cả ba lỗ hổng trên đều đáng lo ngại đến mức thông báo của WordPress khuyến nghị cập nhật ngay lên phiên bản WordPress 5.8.1.

Lỗ hổng API REST

WordPress REST API là một giao diện cho phép các plugin và chủ đề tương tác với lõi WordPress.

wordpres 5.8.1-lo hong rest apiwordpres 5.8.1-lo hong rest api

REST API là nguồn gốc của các lỗ hổng bảo mật, bao gồm gần đây nhất là lỗ hổng Gutenberg Template Library & Redux Framework đã ảnh hưởng đến hơn 1 triệu trang web.

Lỗ hổng này được mô tả là lỗ hổng lộ dữ liệu, có nghĩa là thông tin nhạy cảm có thể bị lộ. Không có chi tiết nào khác tại thời điểm này liên quan đến loại thông tin nào nhưng nó có thể nghiêm trọng như mật khẩu đối với dữ liệu có thể được sử dụng để thực hiện một cuộc tấn công thông qua một lỗ hổng khác.

Lỗ hổng WordPress Gutenberg XSS

Các lỗ hổng Cross-Site Scripting (XSS) xảy ra tương đối thường xuyên. Chúng có thể xảy ra bất cứ khi nào có thông tin người dùng nhập vào như liên hệ hoặc biểu mẫu email, bất kỳ loại thông tin đầu vào nào không được “làm sạch” để ngăn việc tải lên các tập lệnh có thể kích hoạt hành vi không mong muốn trong cài đặt WordPress.

Dự án Open Web Application Security Project (OWASP) mô tả tác hại tiềm ẩn của các lỗ hổng XSS :

“Kẻ tấn công có thể sử dụng XSS để gửi một tập lệnh độc hại đến một người dùng không nghi ngờ. Trình duyệt của người dùng cuối không có cách nào để biết rằng tập lệnh không được tin cậy và sẽ thực thi tập lệnh.

Bởi vì nó cho rằng tập lệnh đến từ một nguồn đáng tin cậy, tập lệnh độc hại có thể truy cập vào bất kỳ cookie, mã thông báo phiên hoặc thông tin nhạy cảm nào khác được trình duyệt giữ lại và sử dụng với trang web đó. Những đoạn mã này thậm chí có thể viết lại nội dung của trang HTML ”.

Lỗ hổng cụ thể này ảnh hưởng đến trình chỉnh sửa khối Gutenberg.

Lỗ hổng thư viện JavaScript Lodash của WordPress

wordpres 5.8.1-rashwordpres 5.8.1-rash

Những lỗ hổng này có thể là mối quan tâm nhất. Thư viện JavaScript Lodash là một tập hợp các tập lệnh được sử dụng bởi các nhà phát triển đã được phát hiện có nhiều lỗ hổng.

Phiên bản mới nhất và an toàn nhất là Lodash 4.17.21.

Trang web CVE List được Bộ An ninh Nội địa Hoa Kỳ tài trợ nêu chi tiết về lỗ hổng bảo mật:

Các phiên bản Lodash trước 4.17.21 dễ bị tấn công bởi Command Injection thông qua chức năng mẫu.”

Có vẻ như có nhiều lỗ hổng khác cũng ảnh hưởng đến thư viện Lodash trong nhánh 4.1.7.

WordPress yêu cầu cập nhật lên phiên bản WordPress 5.8.1 ngay lập tức

Các lỗ hổng bảo mật này tạo thêm cảm giác cấp bách cho bản cập nhật này. Tất cả các nhà xuất bản đều được WordPress khuyến nghị cập nhật.

Thông báo chính thức của WordPress khuyên bạn nên cập nhật:

Vì đây là bản phát hành bảo mật, bạn nên cập nhật các trang web của mình ngay lập tức. Tất cả các phiên bản kể từ WordPress 5.4 cũng đã được cập nhật.

Trên đây là các thông tin về bản phát hành mớiWordPress 5.8.1.Nếu bạn vẫn còn băn khoăn hoặc có câu hỏi nào khác, hãy liên hệ ngay với chúng tôi để được tư vấn miễn phí.

CÔNG TY TNHH CÔNG NGHỆ TRẦN NGUYỄN

Trụ sở: 702/05 Lê Văn Khương, P.Thới An, Quận 12, Tp. Hồ Chí Mính

VP ĐắkLắk: 48/12 Hùng Vương, P. Tự An, TP Buôn Mê Thuột, ĐắkLắk

VP Bình Định: 399 Hồng Lĩnh, P Đập Đá, TX An Nhơn, Tỉnh Bình Định

VP HN: P2004 CT8A, Chung cư Đại Thanh, Tả Thanh Oai, Thanh Trì, Hà Nội

Hotline: (028) 710 99 777

MST: 0312782183 được cấp bởi sở kế hoạch đầu tư Tphcm

Xóa các table không sử dụng trong WordPress database
IOPS SSD là gì? Liệu có đáng để quan tâm?

Bình luận bài viết

Bạn cần tạo website, chat ngay?